Your friend in the digital age
Skip To Menu
Skip To Content
You are here: Residential Home > Support > Internet Support > Connection Problems > Slow Speeds by Checking for Ethernet NIC

Internet

The Internet should add convenience, not headaches. From step-by-step instructions to helpful tips, we'll help you install your equipment, troubleshoot problems, and get the most out of your online experience – minus the migraine.

Back Print Article

Slow Speeds by Checking for Ethernet NIC

Last Updated: Wed, 29 Aug 2012 > Related Articles

23 rated this

Summary

This article provides information on troubleshooting slow speeds by checking for an Ethernet NIC.

Solution

Symptoms

Customer is able to get on line, but has slow download speeds. Web pages open slowly, and the customer has a slow transfer rate when downloading a file.

 

Cause

Most computers are designed to handle Cox High Speed Internet Preferred and Premier speeds. However, some older models have Network Interface Cards (NIC) that are unable to transfer the higher throughput.

USB connections are frequently used for peripheral devices such as keyboard, mouse, scanner, and printer. Everything using USB shares the same bandwidth, causing a competition for speed.

 


Solution

For the best experience, use an Ethernet connection, not USB, to connect a single PC to Cox High Speed Internet service. This will improve both Internet speed and the performance of peripheral devices.
Ethernet is the connection that looks like a large telephone cord, because it has a wider plug and eight wires in the cable instead of four. Ethernet is the most standard way of networking computers, especially in office environments.

There are several versions of Ethernet, the most common in a home environment being 10 Base T and 100 Base T. 10 Base T has a maximum bandwidth of 10 MBPS and 100 Base T has 100 MBPS of bandwidth. (100 Base T has sometimes been called "Fast Ethernet".)


Rate this Article:

Related Topics:

Give us your feedback:

Feedback

Maximum 500 characters

Back Print Article

Need more help?